Author Topic: Weird Problem with my sd card...  (Read 500 times)

Offline gingi

  • Established Member
  • *
  • Posts: 53
  • Props: 0
    • ICQ Messenger - 326800664
    • View Profile
Weird Problem with my sd card...
« on: October 26, 2005, 02:31:56 AM »
I have a really weird problem with my Twinmos 512MB sd card - It works perfectly with my supercard sd, and I can copy every file to and from it.

Except one!
The file in question is the patched version of Lost in Blue (ending in .nds.dsq).
This is driving me crazy -  I made sure I got a clean rom, formatted the card several times, tried another pc reader, tried to copy the file while the sd card had diffrent amounts of data on it, and nothing. The progress bar in the copy window always get most of the way to the end, but then I get the following error: "Cannot copy 0110 - Lost in Blue (U)(Legacy).nds: The request could not be performed because of an I/O device error."

I would of thought the card is broken, but I bought it less then a month ago, and as I said, I can copy every other file I tried to it perfectly.

Did anybody else ever had a similar problem or has any ideas why this is happening?

Offline Slippy

  • Established Member
  • *
  • Posts: 50
  • Props: 0
    • View Profile
Re: Weird Problem with my sd card...
« Reply #1 on: October 26, 2005, 02:38:53 AM »
Lost in Blue is a very picky game...  I think it works unpatched with a passme, however.  I don't know why it wouldn't be copying over to the SC though, that's very odd.  It usually just wouldn't run.
S Setup:
1st Gen DS
Flashme 5 w/ Superpass and Supercard SD
Limited edition Miyamoto signed orange DS Skin
Limited edition Kirby! pink stylus
Now Playing: Nintendogs w/ Jack Russel Terrier

Offline satanduck

  • Established Member
  • *
  • Posts: 259
  • Props: 0
    • ICQ Messenger - 9084034
    • Yahoo Instant Messenger - satanduck
    • View Profile
    • http://keeyeong.multiply.com
Weird Problem with my sd card...
« Reply #2 on: October 26, 2005, 06:35:22 AM »
Sounds like a faulty card to me...
You are not breaking the 64 file limit on FAT now are you?

Does any other file of the same size write-able to your card, while filled to the exact point?

i.e. lets say your card has 500MB of data and writing LiB doesn't work, with the same 500MB still filled, does writing another file of same size or bigger, say, Quenden, work?
nimal Crossing :
Larson" from "Havenile" of Zip code "0816-6534-7899".
Mario Kart DS : 519750-640786 (Larson)
Tony Hawk : 137499-350825 (Larson)

PM me if you added me!

Offline Critical_Impact

  • Established Member
  • *
  • Posts: 226
  • Props: 0
    • View Profile
    • Email
Weird Problem with my sd card...
« Reply #3 on: October 26, 2005, 09:55:31 AM »
Theres a 64 file limit? I've got like 200 files and i can use them all.

Offline gingi

  • Established Member
  • *
  • Posts: 53
  • Props: 0
    • ICQ Messenger - 326800664
    • View Profile
Weird Problem with my sd card...
« Reply #4 on: October 26, 2005, 01:08:13 PM »
Quote from: "satanduck"
Sounds like a faulty card to me...
Does any other file of the same size write-able to your card, while filled to the exact point?

i.e. lets say your card has 500MB of data and writing LiB doesn't work, with the same 500MB still filled, does writing another file of same size or bigger, say, Quenden, work?

I just copied the clean dump rom of ultimate spiderman, which is 64MB, and there was no problem.

That's why I think this problem is so weird, I currently have 64 megabytes roms on my sd card, which I copied to the card multiple times in the past in diffrent locations without problem, yet I have this one file which I can't copy even when I do a format and it's copied as the first file on the sd card...

I also tried trimming the rom before patching it with the sc software but that still didn't work. This made me think that there's only a small part of the file which my sd card don't like for some strange reason, so I tried splitting the rom to 1MB pieces, and I could copy all of them except the 34th piece, which gave me the same error. I then split the 34th piece into 4 pieces, and I couldn't copy the first one (size of 256kb).
This is really weird...

Offline PoTaToE

  • Member
  • *
  • Posts: 19
  • Props: 0
    • View Profile
Weird Problem with my sd card...
« Reply #5 on: October 26, 2005, 01:49:29 PM »
Quote from: "gingi"
Quote from: "satanduck"
Sounds like a faulty card to me...
Does any other file of the same size write-able to your card, while filled to the exact point?

i.e. lets say your card has 500MB of data and writing LiB doesn't work, with the same 500MB still filled, does writing another file of same size or bigger, say, Quenden, work?

I just copied the clean dump rom of ultimate spiderman, which is 64MB, and there was no problem.

That's why I think this problem is so weird, I currently have 64 megabytes roms on my sd card, which I copied to the card multiple times in the past in diffrent locations without problem, yet I have this one file which I can't copy even when I do a format and it's copied as the first file on the sd card...

I also tried trimming the rom before patching it with the sc software but that still didn't work. This made me think that there's only a small part of the file which my sd card don't like for some strange reason, so I tried splitting the rom to 1MB pieces, and I could copy all of them except the 34th piece, which gave me the same error. I then split the 34th piece into 4 pieces, and I couldn't copy the first one (size of 256kb).
This is really weird...
You have a .... Poltergeist!!!!
did you used scandisk with your HD and your SD card? . . . I'd do it.

Offline gingi

  • Established Member
  • *
  • Posts: 53
  • Props: 0
    • ICQ Messenger - 326800664
    • View Profile
Weird Problem with my sd card...
« Reply #6 on: October 26, 2005, 05:03:51 PM »
Quote from: "PoTaToE"
You have a .... Poltergeist!!!!
did you used scandisk with your HD and your SD card? . . . I'd do it.

Yeah, chkdsk (windows xp's version of scandisk) didn't find any errors with my sd card or both partitions of my hard drive.

frame933

  • Guest
Well...
« Reply #7 on: November 01, 2005, 10:36:00 AM »
Quote
Theres a 64 file limit? I've got like 200 files and i can use them all.

Thats one way but i am not sure if it will work with every option.

Offline BLYND

  • Established Member
  • *
  • Posts: 76
  • Props: 0
    • View Profile
Weird Problem with my sd card...
« Reply #8 on: November 02, 2005, 02:37:32 AM »
Fat 16 has a limit on the number of characters in the root directory - Maximum number of files and folders within the root folder =  512 (Long file names can reduce the number of available files and folders in the root folder.)  so i suspect this is where your 64 came from?
If you only seems to be able to fill part of you card then use subdirectories.

Offline gingi

  • Established Member
  • *
  • Posts: 53
  • Props: 0
    • ICQ Messenger - 326800664
    • View Profile
Weird Problem with my sd card...
« Reply #9 on: November 09, 2005, 08:01:47 PM »
ahh!!!! I solved it!!
It was my damn usb hub!! cheap piece of crap!
I noticed it when I tried to copy a file to a mp3 player attached to the hub, and got the same error i got with my sd card... so i connected the card reader directly to my computer and managed to get lost in blue to my sd card. Of course it doesn't work because i'm using flashme, but at this point i don't care anymore  :lol: